量産メモ帳

忘れっぽいのでメモを残しています。

Eclipse 3.4 (Ganymede) で AbstractMethodError が発生する。

スポンサーリンク

いつ頃からなのか分からないが、Eclipse を起動すると、エラーログビューに AbstractMethodError のメッセージが出力されるようになった。
原因はよく分かっていないが、おそらく Mylyn プロジェクトを更新した結果、APIシグネチャが変わってしまい、依存プラグインが MyLyn プラグインAPI を参照できなくなってしまったんだろうと思う。
結果的に、古い依存プラグインを削除して Eclipse を再起動したら、エラーは発生しなくなった。


参考記事: