量産メモ帳

忘れっぽいのでメモを残しています。

必須フィーチャーエラーについて。

スポンサーリンク

「ソフトウェアの更新」で「現在インストール済みのフィーチャーの更新を検索」し、結果として表示されたフィーチャーを選択すると、以下のような必須フィーチャーエラーが発生してしまう。

  • 必須:フィーチャー"org.eclipse.emf.ocl(1.0.0)"、または互換。
  • 必須:フィーチャー"org.eclipse.emf.query(1.0.0)"、または互換。
  • 必須:フィーチャー"org.eclipse.emf.validation(1.0.0)"、または互換。
  • 必須:フィーチャー"org.eclipse.emf.workspace(1.0.0)"、または互換。

とりあえず、以下の各サイトから最新の Release Builds 版の runtime をダウンロード→インストールした。
http://www.eclipse.org/modeling/mdt/downloads/?project=ocl
http://www.eclipse.org/modeling/emf/downloads/?project=query
http://www.eclipse.org/modeling/emf/downloads/?project=validation
http://www.eclipse.org/modeling/emf/downloads/?project=transaction


Eclipse を再起動したら、エラーが出なくなった。


EMF: Eclipse Modeling Framework (Eclipse Series)

EMF: Eclipse Modeling Framework (Eclipse Series)